Buttons not displayed after TR Upgrade to 9.1.5.5

Soumen

Reputable Poster
Dear List,

We recently performed a Tools Upgrade on our PY environment from TR9.1.4.7 to TR9.1.5.5.
The tools release was successful with no issues at any steps.
However we are noticing a very bizarre behavior with one of the JDE URLs.

When logged in using this URL the icons and buttons are missing. However when we log in to the same webservers using the other URLs those buttons and icons are displayed correctly.

The URLs we are using are:

https://xxbizhubyy.ssss.com (This is a load balanced URL and connecting to 2 WebSphere WebServers TXHDCWBS09 and TXHDCWBS10)
This URL is missing icons and buttons.

https://py910.ssss.com (This is also load balanced similar to the above URL and connecting to 2 same WebSphere instances TXHDCWBS09 and TXHDCWBS10)
This one is WORKING and showing all icons and buttons.

If we provide the URLs explicitly like below this also WORKS and shows all the icons and buttons.

http://<server1>.svc.ssss.com:8093/jde/owhtml/
http://<server2>.svc.ssss.com:8093/jde/owhtml/


We have tried with different browsers and versions of IE with similar results.
I am attaching some screen shots for your reference.

Here is our config setup:

JDE E 9.1
TR 9.1.5.5 (upgraded from 9.1.4.7)
iSeries V7R1
WebSphere 8.5.0.2
Windows 2008 R2 (OS for WebServers)
Load Balanced using NetScalar

Our users are primarily testing using IE 9 but the problem is also replicated on IE 10 or IE11 (even Chrome).

Incidentally the same setup works in DV.
I have already performed a binary comparison of the webclient.war folder and could not locate any difference. (except for the servers names / ports numbers etc)
The virtual hosts under websphere console also looks correct and is set as it should be.

In case anyone has noticed this please suggest what was done to resolve it.

Many Thanks,
Soumen
 

Attachments

  • JDE_Home_Page_Buttons_Invisible.jpg
    JDE_Home_Page_Buttons_Invisible.jpg
    30.9 KB · Views: 14
  • Log_in_Screen.jpg
    Log_in_Screen.jpg
    23.6 KB · Views: 14

altquark

Legendary Poster
And you definitely deleted your web-browser cache beforehand - correct ?

Though I'd expect that you did since you're experiencing the same issue between different browsers.

Can the Netscalar provide any logs that provide anything specific ?
 

go_pre

Member
I saw a post in here not too long ago that mentioned something about using underscores in the server name being an issue with some web browsers.

Are there any underscores in your urls?
 

Soumen

Reputable Poster
The netscaler does not have "Integrated caching" enabled. I also tried Ctrl + F5 to clear browser cache and it did not work. Yes those URL existed beofre TR upgrade and were working correctly. I was able to further narrow down the issue by grabbing the URL of 1 icon which was not displaying (right click properties) and noticed this.

Not Working (Icon not displayed on browser)
https://py910.ssss.com/jde/share/images/carousel/disclosure_arrow_ena.png

Working (Icon displaying on browser)
http://py910.ssss.com/jde/share/images/carousel/disclosure_arrow_ena.png

Both the URL are hitting the load balancer (NetScaler) and the SSL offloading happens on the load balancer.

I know https is not an issue because I sucessfully tested an https connection on another websphere instance having SSL enabled and hitting the instance directly without the load balancer in between.

The issue happens when we hit "https" through load balancer/ NetScaler.

Thanks,
Soumen
 

Soumen

Reputable Poster
Just trying to bump up this post and seek some help. We have been able to isolate the issue while connecting through load balancer only. But we have not been able to find a probable cause on our load balancer (Citrix NetScaler) which could cause this issue. Does anyone have any experience with NetSclaer and help me locate where exactly we should check or what logs on NetScaler can give us any clues for this issue?

The NetScaler is installed on the Linux and is version NS10.1 Build 119.7.
Model # of Netscaler is 5650

Thank you!
 
Top