• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

blank lines in output

jeremey_garcia

VIP Member
Good afternoon,

I am new to BI. I attempted it 5 years ago without success, then didn't touch it again till now. I am trying to work on a paycheck and the output is putting a blank line between output when there are left side and right side items. I have tried the @inlines and it took the space away, but combined left side items into one column and did not print right side items. Can anyone provide another idea to try? I've attached an example of the output, the xml and the rtf. Thanks for your help!
 

Attachments

eewon

Active Member
Hi Jeremey

At the end of your code for the Rate and Year to Date fields, you have a line feed. Remove those, and you should get what you're looking for.

Dave
 

jeremey_garcia

VIP Member
Thank you for the response, I was able to get the expected result using @inlines with an outside IF condition before the start of the printing. So it went "for each" then "if" then print the line. That got rid of the blank lines, but then I noticed it still wasn't giving us what we wanted, so now I am trying to use sub-templates to get the desired result, however it is putting a blank space between each line again. I have the @inlines in the choose, when and otherwise commands, but that is not giving us what we want. Can someone point me in the right direction for this one?
 

Attachments

eewon

Active Member
Hi Jeremey

Remove the blanks before and after your 'Body' tag and the extra blank lines will no longer appear. The general advice is to avoid any blanks between consecutive tags, unless you want them to be there in your output.

Dave
 

Attachments

jeremey_garcia

VIP Member
eewon,

Really!? That's all it was!? Wow!!!! all that frustration for that one very important piece of information. I would have never guessed that can cause this! Thanks so much!!!!! That's why I love JDEList!!!!! THANK YOU!!!!!

Hi Jeremey

Remove the blanks before and after your 'Body' tag and the extra blank lines will no longer appear. The general advice is to avoid any blanks between consecutive tags, unless you want them to be there in your output.

Dave
 
Top