• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Automate Startserver after backups

XDWSDFG

Member
We are trying to submit to batch either a QSH command or a CL running the QSH to start our Enterprise One application server.

Our CL and command run fine interactively.
when running in batch - get this message: 001-0012 Error found starting child process. System resources not available to complete request.

Our command:
SBMJOB CMD(STRQSH CMD('cd /qibm/UserData/Websphere/AppServer/V7/Base/profiles/AppSrv01/bin; startServer')) JOB(APPSRV01)

Has anyone else automated the startup of the servers?
 

sbass

Member
Yes, we are starting our E1 app server by batch, and found the command to be case and space sensitive. It also needs the server name you are starting. We also ran into permission issues requiring us to specify the user profile to use to run the command, as well as submitting it to job queue QSYSNOMAX. We also added a delay and started our instances afterwards.

The updated command may look like this depending on the case of your path and names of your servers:
SBMJOB CMD(QSH CMD('cd /QIBM/UserData/WebSphere/AppServer/V7/Base+
/profiles/AppSrv01/bin;startServer server1')) +
JOB(STRSERVER1) JOBQ(QSYS/QSYSNOMAX) USER(QSYSOPR)
MONMSG MSGID(CPF0000)
DLYJOB DLY(30)
SBMJOB CMD(QSH CMD('cd /QIBM/UserData/WebSphere/AppServer/V7/Base+
/profiles/AppSrv01/bin;startServer AS_92')) +
JOB(STRAS92) JOBQ(QSYS/QSYSNOMAX) USER(QSYSOPR)
MONMSG MSGID(CPF0000)
DLYJOB DLY(60)

Good luck!
 
Top