• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

AS400 RPG Call

BillFClark

Active Member
I need to call AS400 RPG programs from within One World Xe (unless the RUNUBE starts working). I have read previous posts and created a batch application and an event rule in the header with a variable equal to my CL lib/pgm (CALL PGM(BCLAR/J55BC001). I then added the business function B34A1030 to call the command line of my variable. When I run the UBE it does not call my CL pgm (I can dspobjd BCLAR/J55BC001 *PGM and see it is not used) and when I view submitted reports it has errored (I can't find out why it errored). I then made sure my variable was long enough (I used a description that was 250 string) and changed my variable to c:\winnt\rmtcmd.exe CALL PGM(BCLAR/J55BC001) and it still errored. I can go to RUN from my PC and enter the rmtcmd and it does run my CL pgm on the AS400.

I am new to all of this. Any suggestions on what I am doing wrong or could do differently?
 

Joseph_Sadler

Well Known Member
Hi Bill.
You have to deploy the UBE, (that executes BSFN B34A1030),
to the enterprise server first. Then run the UBE in batch, not locally.
We use B34A1030 all the time here, and it works great.
We have some that run CL programs with a string of parameters as well.
ie.) CALL PGM(WDSOBJ/J554301) PARM('Y' 'N' '245687' 'OUTQ2')
The only problem we ever had was trying to run it with an override to
LOCAL.
Once the UBEs are deployed with an update package to the AS/400, they work
great.
Feel free to contact me directly if you need more help.

Joseph Sadler,
World Vision Canada.
Helping the children of war and poverty, the world over.
Xe SP13, NT4 SQL 7, AS/400.



BillFClark
<clarksystm@aol.co To: jdeowdevml@jdelist.com
m> cc:
Sent by: Subject: AS400 RPG Call
owner-jdeowdevml@j
delist.com


05/08/01 11:36 AM
Please respond to
jdeowdev






I need to call AS400 RPG programs from within One World Xe (unless the
RUNUBE starts working). I have read previous posts and created a batch
application and an event rule in the header with a variable equal to my CL
lib/pgm (CALL PGM(BCLAR/J55BC001). I then added the business function
B34A1030 to call the command line of my variable. When I run the UBE it
does not call my CL pgm (I can dspobjd BCLAR/J55BC001 *PGM and see it is
not used) and when I view submitted reports it has errored (I can't find
out why it errored). I then made sure my variable was long enough (I used
a description that was 250 string) and changed my variable to c:
\winnt\rmtcmd.exe CALL PGM(BCLAR/J55BC001) and it still errored. I can go
to RUN from my PC and enter the rmtcmd and it does run my CL pgm on the
AS400.

I am new to all of this. Any suggestions on what I am doing wrong or could
do differently?


--------------------------
Visit the forum to view this thread at:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat
=&Board=OWDEV&Number=10372
 

Xe_na_thanks

Active Member
Just my tuppence worth. The other reply seems to have answered your question but I will give you an idea that I have successfully used. Create a file with minimum two columns Lib and PGM (you could have more for parameters) then add a trigger program to process these records after an insert. The IBM manuals can tell you how to setup a trigger program or you can write directly to me and I can tell you how to.

Regards,

Adrian Jackson.
 

BBushley

Active Member
INSIDE THE CL DID YOU DO A CHGLIBL WITH ALL YOUR LIBRARIES. YOU NEED TO DO
THIS BECAUSE THEY ARE NOT BEING PASSED BY ONE WORLD

GOOD LUCK

BOB BUSHLEY
 
Top