AIS host based URL



Reputable Poster
Dear List,

Has anybody implemented AIS with host based URL? How do I avoid providing port based URL on the Oracle Apps settngs and just used host based names?

Since the AIS instance does not have any *.htm file how will the entries in http.conf differ from a HTML instance?

So far I have tried the below combinations with no luck. I can get to the log in page using the App but cannot login with an error saying ... "Application cannot connect to the server"

<VirtualHost *:80>
Alias /jderest "C:\IBM\WebSphere\AppServer\profiles\AppSrv01\installedApps\TXHDCWBS08Node01Cell\AIS_TXHDCWBS08_8096_DV910.ear\JDERestProxy.war"
Redirect permanent /mobile http://TXHDCWBS08.SVC.SSSS.COM:8096
RewriteEngine On
RewriteRule ^/$ /jderest [R,L]
<Directory "C:\IBM\WebSphere\AppServer\profiles\AppSrv01\installedApps\TXHDCWBS08Node01Cell\AIS_TXHDCWBS08_8096_DV910.ear\JDERestProxy.war\WEB_INF">
Order Deny,Allow
Deny from All
<Directory "C:\IBM\WebSphere\AppServer\profiles\AppSrv01\installedApps\TXHDCWBS08Node01Cell\AIS_TXHDCWBS08_8096_DV910.ear\JDERestProxy.war">
Order Deny,Allow
Allow from All

Any clue will be very helpful.

Our installation is:
JDE E9.1
iSeries V7R1
WebSphere 8.5 on Windows 2008 R2

I used a router to perform NAT between a URL and the AIS server, and it works fine. However, I haven't gone through Apache and done the settings directly in OHS - but I would expect this to work.

My demo environment is at - from the firewall, this redirects to an internal firewall server where port 12018 redirects to my JDE AIS instance on port 7181. My JDE HTML Instance is on port 7081.

My AIS configuration is as follows :

HTML Server End Point Host Name (DNS name of my JDE HTML Server)
HTML Server End Point Port : 7081 (the HTML port for my DV instance)
HTML Serve End Point Protocol : http
Default Role : *ALL
Default Environment : JDV910
Keep JAS Session Open (True)
JAS Session Cookie Name : JSESSIONID

Under my JDE HTML Server - on Web Runtime section/Form Service - I had to make "Allowed Hosts=*" to get it to work. That might be your ultimate solution - it took several attempts before I read that * was a valid value !

So hopefully my settings might help you get your settings working !