• Welcome to the upgraded JDELIST forum and thank you for your patience.
    Please restrict discussions and issues regarding the new forum software to the Off Topic forum. We will be monitoring that forum for issues.
    If you have trouble logging in, please reset your password using the forgotten password form: https://www.jdelist.com/community/index.php?lost-password/
    If you are unable to successfully reset your password, please contact us: Click here!
    We hope that you enjoy the upgraded forum.
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Using FTP on the 400

I have a requirement to use FTP to GET from a windows folder.
I have, manually, been able to run the FTP steps, and the desired file ends up in the desired library.

PROGRAMATICALLY, I won't know the name of the file to GET, so I'm trying to do a "DIR disk" or a "LS disk".
I get message 200 "Port command successful", followed by 550 "The system cannot find the file specified".

Per the documentation, the "disk" sub-command should cause FTP to create ftp.diroutput in my current library.
I'm not seeing that happen.

SO, as I wander off to google for answers, I'm asking my JDEList-friends to think about what I'm doing wrong.

(I'm having other issues when doing the MANUAL ftp, but I'm limiting myself to one hurdle at a time).

THANKS.
Frosty
 

TerryWin

Member
Are you able to view the folder and its contents on the Windows box?

What is the exact command your trying to use?

It should look something like the following: LS FolderName (DISK
 
Terry,

Thanks for the response.
I somehow managed to get the LSOUTPUT file that the "LS (disk" sub-command promised me.

I THINK I got lucky when I did a CHGCURLIB (mylib) prior to starting the FTP commands.

Best regards to you, your company, and the entire community of Greene, NY!
Frosty
 
Top